uBuntu下的AptituDE命令为什么要删除某些包来解决依赖关系

源版本不对.如果删的话还会提示这个,一直提示到你把系统删崩了

请把你在终端输入的 apt-get upgrade 或 apt-get install _____ 的输出详细贴到这里,那样比较好解决问题.不然,你要安装什么包、什么依赖包未安装等都没告知,很难解决问题.可以初步尝试以下两个命令:$ sudo apt-get update$ sudo apt-get -f install 看能否解决. apt-get -f install 会尝试 "fix" 解决依赖关系问题.

用apt-get系列命令(具体用法可以上网上查),它会提醒你所缺少的包,但它不会自动下载、安装.比apt-get好用的是,新立德包管理器,它在系统->系统管理->新立德软件包管理器.用它时如果你要安装一个软件,只需要在前面打勾,它会在所依赖的包前自动打勾.选好后,点击“应用”就可以了.

解决方法:使用aptitude包依赖管理工具来帮我们处理,具体使用方法如下:sudo apt-get install aptitudesudo aptitude install g++终端中输入后会提示aptitude给出的解决方案,你可以选择no,会继续提供下一个解决方案,一般前面的方案会是忽略掉依赖冲突,所以想要彻底解决的话可以跳过前面的几种方案,然后再yes解决.(当然这里的话,自己可以看提示选择需要的处理方案)

被提示缺少某些库文件,可是由于不知道库在ubuntu源中 具体的名字,无法正确的apt-get install.现在有一个工具auto-apt可以帮助你解决问题.首先,安装auto-apt:# apt-get install auto-apt 然后,你所要做的仅仅是:# auto-apt run command 这里command指在运行过程中可能出现需求文件不存在问题的命令.例如:# auto-apt run ./configure 一会儿,它就会告诉你要安装所需的软件包并自动转到apt-get处理.如果你正在运行X,就会一个图形界面提示窗口.

在终端下输入sudo apt-get install aptitude然后再输入sudo aptitude install uctimsclient

建议把已安装的卸载了或者用aptitude 解决比apt-get更强

本人同大多封釉一样,用ubuntu降级过程中第三步出现idevicerestore未知命令的错误. 发现是由于依赖库缺少或者依赖库版本过低问题导致.故只要安装正确的依赖库就行.. 下面教程开始: 打开终端,输入 su,接着输入密码.

* apt-get update在修改/etc/apt/sources.list或者/etc/apt/preferences之后运行该命令.此外您需要定期运行这一命令以确保您的软件包列表是最新的.* apt-get install packagename安装一个新软件包(参见下文的aptitude )* apt-get

联系就是都是管理软件包的. 区别,从网上搜的: aptitude 解决得更好的地方: install, remove, reinstall(apt-get无此功能), show(apt-get无此功能), search(apt-get无此功能), hold(apt-get无此功能), unhold(apt-get无此功能), ap

相关文档

ddgw.net
369-e.com
9371.net
zxqt.net
mdsk.net
电脑版